Bashell.com is upgraded to Plume 0.4.0!

bashell.com ปรับรุ่นเป็น Plume 0.4.0 แล้ว

Yeah!

Bashell.com is powered by Plume 0.4.0 now.

The process is pretty easy, if you are running you instance from docker-compose, you can just follow this page https://docs.joinplu.me/update/docker.

But because Bashell.com is running from my customized shell script, so I just modify my original script as below:

#!/bin/bash

VERSION=v0.4.0

docker pull docker.io/plumeorg/plume:$VERSION

docker stop plume
docker rm plume

docker run --rm \
    --link=postgres \
    -v /data/plume/static/media:/app/static/media:z \
    -v /data/plume/env:/app/.env:z \
    -v /data/plume/search_index:/app/search_index:z \
    docker.io/plumeorg/plume:$VERSION \
    plm migration run

docker run -d --restart=always --name=plume \
    --link=postgres \
    -v /data/plume/static/media:/app/static/media:z \
    -v /data/plume/env:/app/.env:z \
    -v /data/plume/search_index:/app/search_index:z \
    docker.io/plumeorg/plume:$VERSION

This is a public Plume instance running on my personal computer at home. Do not expect it to be available 24/7. It also consumes 50W or around 150 THB a month. So, if you may kindly donate 10% for my electricity bill, yes?